<!DOCTYPE html><html class="no-js" lang="en-US"><head><meta charset="UTF-8"><meta name="viewport" content="width=device-width, initial-scale=1.0"><link media="all" href="https://wnur-transfer.soc.northwestern.edu/wp-content/cache/autoptimize/css/autoptimize_074d1608fe1622cb58d9eb5076345f8f.css" rel="stylesheet" /><title>Evanston native David Safran on the re-release of Delicate Parts &#8211; WNUR</title><style>@font-face {
	font-family: 'Glyphicons';
	font-style: normal;
	font-weight: normal;
	src: ;
	src: local('Glyphicons'), local('Glyphicons'), url('https://wnur.org/wp-content/uploads/2019/05/glyphicons-halflings-regular.woff') format('woff');
}</style><link rel="preload" href="https://wnur.org/wp-content/uploads/2019/05/glyphicons-halflings-regular.woff" as="font" type="font/woff2" crossorigin><link rel="preload" href="https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/vendors/font-awesome/webfonts/fa-brands-400.woff2" as="font" type="font/woff2" crossorigin><link rel="preload" href="https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/vendors/font-awesome/webfonts/fa-regular-400.woff2" as="font" type="font/woff2" crossorigin><link rel="preload" href="https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/vendors/font-awesome/webfonts/fa-solid-900.woff2" as="font" type="font/woff2" crossorigin><link rel="preload" href="https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/css/fonts/flaticons-custom/flaticon.woff" as="font" type="font/woff2" crossorigin><link rel="preload" href="https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/css/fonts/linea-iconfont/fonts/linea.woff" as="font" type="font/woff2" crossorigin><meta name='robots' content='max-image-preview:large' /><link rel='dns-prefetch' href='//wnur-transfer.soc.northwestern.edu' /><link rel='dns-prefetch' href='//fonts.googleapis.com' /><link rel='dns-prefetch' href='//s.w.org' /><link rel="alternate" type="application/rss+xml" title="WNUR &raquo; Feed" href="https://wnur.org/feed/" /><meta property="og:type" content="article"><meta property="og:title" content="Evanston native David Safran on the re-release of Delicate Parts"><meta property="og:url" content="https://wnur.org/evanston-native-david-safran-on-the-re-release-of-delicate-parts/"><meta property="og:site_name" content="WNUR"><meta property="og:description" content="BY REBECCA SHAID Over 20 years since his first appearance on WNUR and nine years since the release of his album, Delicate Parts, David Safran joined WNUR to discuss the re-release of his LP and his passion for music.  After recently being signed by a record label, Safran remastered and re-released his 2012 album Delicate&hellip;"><meta property="og:image" content="https://media.soc.northwestern.edu/wnur/2021/06/06212317/david-safran.jpg"><link itemprop="image" href="https://media.soc.northwestern.edu/wnur/2021/06/06212317/david-safran.jpg">  <script>window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/13.0.1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/wnur-transfer.soc.northwestern.edu\/wp-includes\/js\/wp-emoji-release.min.js?ver=aef9b5373b8bdd9055cb94bf6eaf8593"}};
			!function(e,a,t){var n,r,o,i=a.createElement("canvas"),p=i.getContext&&i.getContext("2d");function s(e,t){var a=String.fromCharCode;p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,e),0,0);e=i.toDataURL();return p.clearRect(0,0,i.width,i.height),p.fillText(a.apply(this,t),0,0),e===i.toDataURL()}function c(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(o=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},r=0;r<o.length;r++)t.supports[o[r]]=function(e){if(!p||!p.fillText)return!1;switch(p.textBaseline="top",p.font="600 32px Arial",e){case"flag":return s([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])?!1:!s([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!s([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]);case"emoji":return!s([55357,56424,8205,55356,57212],[55357,56424,8203,55356,57212])}return!1}(o[r]),t.supports.everything=t.supports.everything&&t.supports[o[r]],"flag"!==o[r]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[o[r]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(n=t.source||{}).concatemoji?c(n.concatemoji):n.wpemoji&&n.twemoji&&(c(n.twemoji),c(n.wpemoji)))}(window,document,window._wpemojiSettings);</script> <style>img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}</style><style id='wprp_style-css-inline-css'>.wprp_mini_wrapper, .wprp_mini_wrapper .wprp_cover_hole {background: #fff;}.wprp_mini_wrapper .wprp_cover_overlay {background: #011627;}.wprp_mini_wrapper .wprp_stroke {stroke: #011627;}.wprp_mini_wrapper .wprp_fill {fill: #011627;}.wprp_mini_wrapper .wprp_btn:hover .wprp_stroke {stroke: #00A8E8;}.wprp_mini_wrapper .wprp_btn:hover .wprp_fill {fill: #00A8E8;}.wprp_mini_wrapper .wprp_radio_name {color: #011627;}.wprp_mini_wrapper .wprp_title {color: #011627;}.wprp_mini_wrapper .wprp_artist {color: #485e6f;}.wprp_player_wrapper, .wprp_player_wrapper .wprp_cover_hole  {background: #fafafa;}.wprp_player_wrapper .wprp_cover_overlay {background: #011627;}.wprp_player_wrapper .wprp_title {color: #011627;}.wprp_player_wrapper .wprp_artist {color: #485e6f;}.wprp_player_controll {background: #fff;}.wprp_player_controll .wprp_stroke {stroke: #011627;}.wprp_player_controll .wprp_fill {fill: #011627;}.wprp_player_controll .wprp_btn:hover .wprp_stroke {stroke: #00A8E8;}.wprp_player_controll .wprp_btn:hover .wprp_fill, .wprp_volume.muted path {fill: #00A8E8;}.wprp_song_list:before, .wprp_song_history .wprp_cover_hole {background: #fafafa;}.wprp_item:before {background: #fff;}.wprp_song_cover {background: #011627;}.wprp_song_history .wprp_title {color: #011627;}.wprp_song_history .wprp_artist {color: #485e6f;}.wprp_radio_list:before {background: #fafafa;}.wprp_radio:before {background: #fff;}.wprp_radio {color: #011627;}.wprp_scroll_rail .ui-slider-handle {background: #011627;}</style><link rel='stylesheet' id='timetable_font_lato-css'  href='//fonts.googleapis.com/css?family=Lato%3A400%2C700&#038;ver=aef9b5373b8bdd9055cb94bf6eaf8593' media='all' /><!-- <link rel='stylesheet' id='typolab-0d13c6cbd5d64cd172da356b1bd5bee1-css'  href='https://wnur.org/wp-content/themes/kalium-child/fonts.css?ver=861db3850e408fd79b3fca27d4155e0c' media='all' /> -->
<link rel="stylesheet" type="text/css" href="//wnur-transfer.soc.northwestern.edu/wp-content/cache/wpfc-minified/lpq981l4/fdk3s.css" media="all"/><link rel='stylesheet' id='typolab-2542f8522f13376743b278227100048d-css'  href='https://fonts.googleapis.com/css?family=IBM+Plex+Mono%3A500&#038;subset=latin&#038;display=swap&#038;ver=861db3850e408fd79b3fca27d4155e0c' media='all' /> <script type="text/javascript">var ajaxurl = ajaxurl || 'https://wnur-transfer.soc.northwestern.edu/wp-admin/admin-ajax.php';</script> <style id="typolab-font-variants">.font-4{font-family:'Fipps Regular'}.main-header.menu-type-standard-menu .standard-menu-container div.menu>ul>li>a,.main-header.menu-type-standard-menu .standard-menu-container ul.menu>li>a,.main-header.menu-type-standard-menu .standard-menu-container div.menu>ul ul li a,.main-header.menu-type-standard-menu .standard-menu-container ul.menu ul li a{font-family:'Fipps Regular'}.main-header.menu-type-full-bg-menu .full-screen-menu nav ul li a,.main-header.menu-type-full-bg-menu .full-screen-menu nav div.menu>ul ul li a,.main-header.menu-type-full-bg-menu .full-screen-menu nav ul.menu ul li a{font-family:'Fipps Regular'}.top-menu-container .top-menu ul li a,.top-menu div.menu>ul>li ul>li>a,.top-menu ul.menu>li ul>li>a,.top-menu-container .widget h3,.top-menu-container .widget,.top-menu-container .widget p,.top-menu-container .widget div{font-family:'Fipps Regular'}.mobile-menu-wrapper .mobile-menu-container div.menu>ul>li>a,.mobile-menu-wrapper .mobile-menu-container ul.menu>li>a,.mobile-menu-wrapper .mobile-menu-container .cart-icon-link-mobile-container a,.mobile-menu-wrapper .mobile-menu-container .search-form input,.mobile-menu-wrapper .mobile-menu-container div.menu>ul>li ul>li>a,.mobile-menu-wrapper .mobile-menu-container ul.menu>li ul>li>a{font-family:'Fipps Regular'}.font-1{font-family:'IBM Plex Mono';font-weight:500}h1,h2,h3,h4,h5,h6{font-family:'IBM Plex Mono';font-weight:500}body,p,th,tr,td{font-family:'IBM Plex Mono';font-weight:500}.site-footer .footer-widgets .widget h1,.site-footer .footer-widgets .widget h2,.site-footer .footer-widgets .widget h3,.site-footer .footer-widgets .widget .textwidget,.site-footer .footer-widgets .widget p,.copyrights,.site-footer .footer-bottom-content a,.site-footer .footer-bottom-content p{font-family:'IBM Plex Mono';font-weight:500}.font-6{font-family:'Glyphicons';font-style:normal;font-weight:normal}body,p,th,tr,td{font-size:14px}.site-footer .footer-widgets .widget h1,.site-footer .footer-widgets .widget h2,.site-footer .footer-widgets .widget h3,.site-footer .footer-widgets .widget .textwidget,.site-footer .footer-widgets .widget p,.copyrights,.site-footer .footer-bottom-content a,.site-footer .footer-bottom-content p{font-size:11px}h1,h2,h3,h4,h5,h6{text-transform:uppercase}</style><script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-includes/js/jquery/jquery.min.js?ver=3.5.1' id='jquery-core-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-includes/js/jquery/jquery-migrate.min.js?ver=3.3.2' id='jquery-migrate-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/plugins/rplayer/assets/js/js.cookie.js?ver=aef9b5373b8bdd9055cb94bf6eaf8593' id='js.cookie-js'></script> <script type='text/javascript' id='wprp_script-js-js-extra'>var wprp_ajax = {"plugin_url":"https:\/\/wnur-transfer.soc.northwestern.edu\/wp-content\/plugins\/rplayer\/","url":"https:\/\/wnur-transfer.soc.northwestern.edu\/wp-admin\/admin-ajax.php"};</script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/plugins/rplayer/assets/js/wprp_script.js?ver=aef9b5373b8bdd9055cb94bf6eaf8593' id='wprp_script-js-js'></script> <script type='text/javascript' id='wprp_script-js-js-after'>jQuery(document).ready(function ($) {
if (Cookies.get('wprp_data')) {
var data = Cookies.getJSON('wprp_data');
var autoplay = data.playing;
var current = data.current;
} else {
var autoplay = false;
var current = null;
}
$('.wprp_wrapper').wprp({
position: 'left',
autoplay: autoplay,
current: current,
updateInterval: 30,
playlist:
[{"radioname":"WNUR 89.3 FM HD1","radiourl":"https:\/\/stream.rcs.revma.com\/w4pmmfkdx4zuv\t\t\t"}]
});
});</script> <link rel="https://api.w.org/" href="https://wnur.org/wp-json/" /><link rel="alternate" type="application/json" href="https://wnur.org/wp-json/wp/v2/posts/10695" /><link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://wnur-transfer.soc.northwestern.edu/xmlrpc.php?rsd" /><link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://wnur-transfer.soc.northwestern.edu/wp-includes/wlwmanifest.xml" /><link rel="canonical" href="https://wnur.org/evanston-native-david-safran-on-the-re-release-of-delicate-parts/" /><link rel='shortlink' href='https://wnur.org/?p=10695' /><link rel="alternate" type="application/json+oembed" href="https://wnur.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwnur.org%2Fevanston-native-david-safran-on-the-re-release-of-delicate-parts%2F" /><link rel="alternate" type="text/xml+oembed" href="https://wnur.org/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fwnur.org%2Fevanston-native-david-safran-on-the-re-release-of-delicate-parts%2F&#038;format=xml" /> <style type="text/css">.wpb_wrapper #sb_instagram .sbi_follow_btn a {
  text-align: center;
	display: inline-block;
	background-color: #ebebeb;
	color: #666;
	padding-top: 14px;
	padding-bottom: 14px;
	padding-left: 20px;
	padding-right: 20px;
	border-radius: 5px;
	-moz-transition: all .2s ease-in-out;
	-webkit-transition: all .2s ease-in-out;
	transition: all .2s ease-in-out;
	margin: 20px auto;
        font-size: 14px;
}

.wpb_wrapper #sb_instagram .sbi_follow_btn a:hover {
	-moz-transition: all .2s ease-in-out;
	-webkit-transition: all .2s ease-in-out;
	transition: all .2s ease-in-out;
	color: #ebebeb;
	background-color: #333;
        box-shadow: none;
}

.wpb_wrapper #sb_instagram .sbi_follow_btn a:focus, .wpb_wrapper #sb_instagram .sbi_follow_btn a:visited {
        box-shadow: none;
}</style> <script>document.documentElement.className = document.documentElement.className.replace( 'no-js', 'js' );</script> <style id="theme-custom-css">body {}@media only screen  and (max-device-width: 480px)  and (orientation: portrait) {    .ifc, .ifc-popup, .ifc-popup-min {      display: none !important;    }}</style><link rel="shortcut icon" href="https://media.soc.northwestern.edu/wnur/2019/06/19212237/favicon3.png"> <script>var mobile_menu_breakpoint = 768;</script><style data-appended-custom-css="true">@media screen and (min-width:769px) { .mobile-menu-wrapper,.mobile-menu-overlay,.header-block__item--mobile-menu-toggle {display: none;} }</style><style data-appended-custom-css="true">@media screen and (max-width:768px) { .header-block__item--standard-menu-container {display: none;} }</style><meta name="generator" content="Powered by WPBakery Page Builder - drag and drop page builder for WordPress."/> <noscript><style>.wpb_animate_when_almost_visible { opacity: 1; }</style></noscript></head><body class="post-template-default single single-post postid-10695 single-format-standard wpb-js-composer js-comp-ver-6.6.0 vc_responsive"><div class="mobile-menu-wrapper mobile-menu-slide"><div class="mobile-menu-container"><ul id="menu-mobile-menu" class="menu"><li id="menu-item-5534" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5534"><a href="https://wnur.org/about/">About</a></li><li id="menu-item-5535" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5535"><a href="https://wnur.org/about/content/">Content</a></li><li id="menu-item-5536" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5536"><a href="https://wnur.org/schedule/">Schedule</a></li><li id="menu-item-5538" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5538"><a href="https://wnur.org/recent-playlists/">Playlists</a></li><li id="menu-item-7015" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7015"><a target="_blank" rel="noopener" href="https://catalyzer.northwestern.edu/project/16899">Donate</a></li><li id="menu-item-5539" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5539"><a href="https://wnur.org/contact/">Contact</a></li><li id="menu-item-5540" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5540"><a href="https://wnur.org/contact/get-involved/">Get Involved</a></li></ul></div></div><div class="mobile-menu-overlay"></div><div class="wrapper" id="main-wrapper"><style data-appended-custom-css="true">.header-block, .site-header--static-header-type {padding-top: 50px;}</style><style data-appended-custom-css="true">@media screen and (max-width: 992px) { .header-block, .site-header--static-header-type {padding-top: 25px;} }</style><style data-appended-custom-css="true">@media screen and (max-width: 768px) { .header-block, .site-header--static-header-type {padding-top: 16.666666666667px;} }</style><style data-appended-custom-css="true">.header-block, .site-header--static-header-type {padding-bottom: 15px;}</style><style data-appended-custom-css="true">@media screen and (max-width: 992px) { .header-block, .site-header--static-header-type {padding-bottom: 7.5px;} }</style><style data-appended-custom-css="true">@media screen and (max-width: 768px) { .header-block, .site-header--static-header-type {padding-bottom: 5px;} }</style><header class="site-header main-header menu-type-standard-menu is-sticky"><div class="header-block"><div class="header-block__row-container container"><div class="header-block__row header-block__row--main"><div class="header-block__column header-block__logo header-block--auto-grow"><style data-appended-custom-css="true">.logo-image {width:130px;height:63px;}</style><style data-appended-custom-css="true">@media screen and (max-width: 768px) { .logo-image {width:130px;height:63px;} }</style><a href="https://wnur.org" class="header-logo logo-image"> <img   width="130" height="130" alt="WNUR" data-src="https://media.soc.northwestern.edu/wnur/2019/08/19211716/main-logo-bl-01.svg" class="main-logo lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw==" /><noscript><img src="https://media.soc.northwestern.edu/wnur/2019/08/19211716/main-logo-bl-01.svg" class="main-logo" width="130" height="130" alt="WNUR"/></noscript> </a></div><div class="header-block__column header-block--content-right header-block--align-right"><div class="header-block__items-row"><div class="header-block__item header-block__item--type-menu-main-menu header-block__item--standard-menu-container"><div class="standard-menu-container menu-skin-main"><nav class="nav-container-main-menu"><ul id="menu-menu" class="menu"><li id="menu-item-113" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-113"><a href="https://wnur.org/about/"><span>About</span></a><ul class="sub-menu"><li id="menu-item-384" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-384"><a href="https://wnur.org/about/content/"><span>Content</span></a></li></ul></li><li id="menu-item-907" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-907"><a href="https://wnur.org/schedule/"><span>Schedule</span></a></li><li id="menu-item-721" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-721"><a href="https://wnur.org/recent-playlists/"><span>Playlists</span></a></li><li id="menu-item-7014" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-7014"><a target="_blank" rel="noopener" href="https://wnur.org/donate"><span>Donate</span></a></li><li id="menu-item-70" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-has-children menu-item-70"><a href="https://wnur.org/contact/"><span>Contact</span></a><ul class="sub-menu"><li id="menu-item-9231" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-9231"><a href="https://wnur.org/contact/newsletter/"><span>Newsletter</span></a></li><li id="menu-item-5454" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5454"><a href="https://wnur.org/contact/get-involved/"><span>Get Involved</span></a></li></ul></li></ul></nav></div></div><div class="header-block__item header-block__item--type-search-field header-block__item--hide-on-mobile"><div class="header-search-input menu-skin-main"><form role="search" method="get" action="https://wnur.org/"><div class="search-field"> <span>Search site...</span> <input type="search" value="" autocomplete="off" name="s"/></div><div class="search-icon"> <a href="#" data-animation="scale" aria-label="Search site"> <?xml version="1.0" encoding="utf-8"?> <svg height="24" width="24" version="1.1" xmlns="http://www.w3.org/2000/svg" xmlns:xlink="http://www.w3.org/1999/xlink" x="0px" y="0px"
 viewBox="0 0 1417.3 1417.3" style="enable-background:new 0 0 1417.3 1417.3;" xml:space="preserve"><style type="text/css">.st0{display:none;}
	.st1{display:inline;}</style><g id="search-one"> <path d="M976.2,925.2c90.6-98.1,147.1-229.4,147.1-374.1C1123.4,247.7,876.5,0,572.2,0S21.1,247.7,21.1,551.1
 s246.9,551.1,551.1,551.1c123.9,0,237.7-40.7,330-109.7l409.8,409.8c10,10,22.4,15,34.9,15s25.8-5,34.9-15
 c19.1-19.1,19.1-50.7,0-70.7L976.2,925.2z M120.8,551.1c0-248.6,202-451.4,451.4-451.4c248.6,0,451.4,202,451.4,451.4
 s-202,451.4-451.4,451.4S120.8,799.7,120.8,551.1z"/> </g> <g id="search-two" class="st0"> <path class="st1" d="M976.2,925.2c90.6-98.1,147.1-229.4,147.1-374.1C1123.4,247.7,876.5,0,572.2,0S21.1,247.7,21.1,551.1
 s246.9,551.1,551.1,551.1c123.9,0,237.7-40.7,330-109.7l409.8,409.8c10,10,22.4,15,34.9,15s25.8-5,34.9-15
 c19.1-19.1,19.1-50.7,0-70.7L976.2,925.2z"/> </g> </svg> </a></div></form></div></div><div class="header-block__item header-block__item--type-menu-main-menu header-block__item--mobile-menu-toggle"><a href="#" class="toggle-bars menu-skin-main" aria-label="Toggle navigation" data-action="mobile-menu"> <span class="toggle-bars__column"> <span class="toggle-bars__bar-lines"> <span class="toggle-bars__bar-line toggle-bars__bar-line--top"></span> <span class="toggle-bars__bar-line toggle-bars__bar-line--middle"></span> <span class="toggle-bars__bar-line toggle-bars__bar-line--bottom"></span> </span> </span> </a></div></div></div></div></div></div></header><div class="single-post"><div class="container"><div class="row"><div class="post-image"> <a href="https://media.soc.northwestern.edu/wnur/2021/06/06212317/david-safran.jpg" class="featured-image"> <span class="image-placeholder" style="padding-bottom:100.00000000%;background-color:#eeeeee"><img width="700" height="700" class="attachment-original size-original img-10696 lazyload" alt="" data-src="https://media.soc.northwestern.edu/wnur/2021/06/06212317/david-safran.jpg" data-srcset="https://media.soc.northwestern.edu/wnur/2021/06/06212317/david-safran.jpg 700w, https://media.soc.northwestern.edu/wnur/2021/06/06212317/david-safran-300x300.jpg 300w, https://media.soc.northwestern.edu/wnur/2021/06/06212317/david-safran-150x150.jpg 150w, https://media.soc.northwestern.edu/wnur/2021/06/06212317/david-safran-468x468.jpg 468w, https://media.soc.northwestern.edu/wnur/2021/06/06212317/david-safran-558x558.jpg 558w, https://media.soc.northwestern.edu/wnur/2021/06/06212317/david-safran-655x655.jpg 655w, https://media.soc.northwestern.edu/wnur/2021/06/06212317/david-safran-266x266.jpg 266w" data-sizes="(max-width: 700px) 100vw, 700px" /></span> </a></div><article id="post-10695" class="post post-10695 type-post status-publish format-standard has-post-thumbnail hentry category-release"><section class="post--column post-body"><header class="entry-header"><h1 class="post-title entry-title">Evanston native David Safran on the re-release of Delicate Parts</h1></header><section class="post-meta-only"><div class="post-meta date updated published"> <i class="icon icon-basic-calendar"></i> June 6, 2021</div><div class="post-meta category"> <i class="icon icon-basic-folder-multiple"></i> <a href="https://wnur.org/category/release/" rel="category tag">Release</a></div></section><section class="post-content post-formatting"><h3>BY REBECCA SHAID</h3><p><span style="font-weight: 400;">Over 20 years since his first appearance on WNUR and nine years since the release of his album, </span><i><span style="font-weight: 400;">Delicate Parts</span></i><span style="font-weight: 400;">, David Safran joined WNUR to discuss the re-release of his LP and his passion for music. </span></p><p><span style="font-weight: 400;">After recently being signed by a record label, Safran remastered and re-released his 2012 album </span><i><span style="font-weight: 400;">Delicate parts </span></i><span style="font-weight: 400;">on April 14. In his album, Safran provides listeners with a soothingly unique musical experience that makes you feel like you’re listening to live music at a nice restaurant. </span></p><p><span style="font-weight: 400;">But this album wasn’t the first thing the Chicago area heard from him. The Evanston resident has been a part of the Chicago music scene since middle school, and after joining the Chicago ‘90s punk scene, the eighth grader made his debut on WNUR— the only radio station that played local punk rock, Safran noted.  </span></p><p><span style="font-weight: 400;">“It seemed like it was 20 kids just sort of packed into this little studio in Evanston,” he said. “I remember we were all intimidated by these ancient college kids. And they thought our band was cool. So that was even, you know, more astounding.”</span></p><p><span style="font-weight: 400;">It was Safran’s first band, the Apathetics, who performed on WNUR </span><i><span style="font-weight: 400;">and</span></i><span style="font-weight: 400;"> whose song was a new addition on his re-released album. After realizing one of their songs had been digitized and hearing it for the first time in over 20 years, Safran decided to make a cover himself, and his label decided it was just good enough to be included on the re-release. </span></p><p><span style="font-weight: 400;">“I loved the song so much, I thought, ‘Would it be strange to cover a song recorded when I was, like, 14 or 15, but done in my mid-30s?’ and I did it. It&#8217;s called </span><i><span style="font-weight: 400;">The Weekend</span></i><span style="font-weight: 400;">,” he said. </span></p><p><span style="font-weight: 400;">Although he spent many years in the punk band world, the singer-songwriter said he eventually realized bands were limiting his ability to explore outside of punk, leading to his solo career and the creation of </span><i><span style="font-weight: 400;">Delicate Parts. </span></i></p><p><span style="font-weight: 400;">After beginning the album in college and spending the following seven years working on it, Safran was ready to release it in 2012</span><i><span style="font-weight: 400;">, </span></i><span style="font-weight: 400;">but wanting to do it under his own terms, he first released the album without the backing of a label.</span></p><p><span style="font-weight: 400;">“I did independently reach an audience, it just wasn&#8217;t enough to push it out. I didn&#8217;t have a team, and then I lost a manager,” Safran said about his first release. “You can see just a series of small failures that kind of added up to ‘Alright, now you&#8217;re going to just make music for yourself, and for, you know, a couple 100 people.’”</span></p><p><span style="font-weight: 400;">But Safran returns strong today with a fresh product of his old project; he was recently signed by Tiki Core Records. The album heard today now includes the cover of </span><i><span style="font-weight: 400;">The Weekend</span></i><span style="font-weight: 400;"> and omits two songs from the original LP that Safran said his label encouraged him to drop. </span></p><p><span style="font-weight: 400;">Safran said that this release is much different than his last, being completely digital due to the pandemic. Not sharing his music live and in-person is a challenge, he said, but making jingles independently throughout his adult life has prepared him for the pandemic music scene. </span></p><p><span style="font-weight: 400;">“I was already accustomed to the freedoms and limitations of recording in your closet prior to the pandemic, and so that just didn&#8217;t really change anything,” he said. </span></p><p><span style="font-weight: 400;">Working as a freelance writer and jingle-maker has taken his work all around the world. He has even developed a fan base in Argentina, where he’s been doing advertisement music projects for almost a decade. His album has gained a lot of attention there since his label decided to do a South America campaign. </span></p><p><span style="font-weight: 400;">While the label classified the album as dark cabaret, Safran says he doesn’t think that’s entirely accurate, and he describes his songs as containing elements of post punk, baroque pop or indie pop. Either way, the boundary-breaking tunes will be sure to strike a chord. </span></p><p><span style="font-weight: 400;">Ultimately, Safran’s music cannot be put into a box, and Safran has proved through his time in the music industry that he can’t either. His persistence and resilience is what has kept him relevant all these years— dating all the way back to his 8th grade visit to WNUR.  </span></p></section></section><nav class="post-navigation"><div class="post-navigation__column"> <a href="https://wnur.org/wnur-kicks-off-its-annual-phoneathon-fundraiser/" class="adjacent-post-link adjacent-post-link--prev adjacent-post-link--has-icon adjacent-post-link--arrow-left"> <span class="adjacent-post-link__icon"> <i class="flaticon-arrow427"></i> </span> <span class="adjacent-post-link__text"> <span class="adjacent-post-link__text-secondary"> Older Post </span> <span class="adjacent-post-link__text-primary"> WNUR kicks off its annual Phoneathon fundraiser </span> </span> </a></div><div class="post-navigation__column post-navigation__column--right"></div></nav></article></div></div></div> <script type='text/javascript'>var _gaq = _gaq || [];
	_gaq.push(['_setAccount', 'UA-144189203-1']);
_gaq.push(['_trackPageview']);

	(function() {
		var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
		ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
		var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
	})();</script> </div><footer id="footer" role="contentinfo" class="site-footer main-footer footer-bottom-horizontal site-footer-inverted main-footer-inverted"><div class="container"><div class="footer-widgets"><div class="footer--widgets widget-area widgets--columned-layout widgets--columns-5" role="complementary"><div id="custom_html-7" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget"><img  width="125px" alt="WNUR" data-src="/wp-content/uploads/2019/08/main-logo-wh-02.svg" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="><noscript><img src="/wp-content/uploads/2019/08/main-logo-wh-02.svg" width="125px" alt="WNUR"></noscript></div></div><div id="custom_html-10" class="widget_text widget widget_custom_html"><div class="textwidget custom-html-widget">&nbsp;</div></div><div id="nav_menu-2" class="widget widget_nav_menu"><h2 class="widgettitle">Explore</h2><div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li id="menu-item-5087" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-home menu-item-5087"><a href="https://wnur.org/">Home</a></li><li id="menu-item-5085" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5085"><a href="https://wnur.org/about/">About</a></li><li id="menu-item-5083" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5083"><a href="https://wnur.org/schedule/">Schedule</a></li><li id="menu-item-5084" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5084"><a href="https://wnur.org/recent-playlists/">Playlists</a></li><li id="menu-item-5086" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-5086"><a href="https://wnur.org/contact/">Contact</a></li></ul></div></div><div id="nav_menu-3" class="widget widget_nav_menu"><h2 class="widgettitle">Connect</h2><div class="menu-footer-social-container"><ul id="menu-footer-social" class="menu"><li id="menu-item-5088" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5088"><a target="_blank" rel="noopener" href="https://www.instagram.com/wnur89.3/">Instagram</a></li><li id="menu-item-5089" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5089"><a target="_blank" rel="noopener" href="https://www.facebook.com/wnurfm">Facebook</a></li><li id="menu-item-5090" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-5090"><a target="_blank" rel="noopener" href="https://twitter.com/wnur893">Twitter</a></li></ul></div></div><div id="custom_html-9" class="widget_text widget widget_custom_html"><h2 class="widgettitle">Info</h2><div class="textwidget custom-html-widget"><div class="menu-footer-nav-container"><ul id="menu-footer-nav" class="menu"><li>WNUR 89.3 FM</li><li>1877 Campus Drive</li><li>Evanston, IL</li><li>60208</li></ul></div></div></div></div></div><hr></div><div class="footer-bottom"><div class="container"><div class="footer-bottom-content"><div class="footer-content-right"><p>WEBSITE BY <a href="http://sub.tm" target="_blank">SUB.TM</a></p></div><div class="footer-content-left"><div class="copyrights site-info"><p>© 2020 WNUR. ALL RIGHTS RESERVED. <a href="https://publicfiles.fcc.gov/fm-profile/wnur-fm" target="_blank">WNUR PUBLIC FILE</a>.</p></div></div></div></div></div></footer><div class="wprp_wrapper pos-left" style="z-index: 9999"></div> <script type="text/javascript">var sbiajaxurl = "https://wnur-transfer.soc.northwestern.edu/wp-admin/admin-ajax.php";</script> <script type="application/ld+json">{"@context":"https:\/\/schema.org\/","@type":"Organization","name":"WNUR","url":"https:\/\/wnur.org","logo":"https:\/\/media.soc.northwestern.edu\/wnur\/2019\/08\/19211716\/main-logo-bl-01.svg"}</script> <script type='text/javascript' id='iflychat-ajax-js-extra'>var iflychat_chatcamp_check = "0";
var iflychat_app_id = "9a28840d-f5a7-4bb9-be4a-8601867ad495";
var iflychat_external_cdn_host = "cdn.iflychat.com";</script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/plugins/iflychat/js/iflychat.js?ver=aef9b5373b8bdd9055cb94bf6eaf8593' id='iflychat-ajax-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/plugins/iflychat/js/iflychat-popup.js?ver=aef9b5373b8bdd9055cb94bf6eaf8593' id='iflychat-popup-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-includes/js/jquery/ui/core.min.js?ver=1.12.1' id='jquery-ui-core-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-includes/js/jquery/ui/mouse.min.js?ver=1.12.1' id='jquery-ui-mouse-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-includes/js/jquery/ui/slider.min.js?ver=1.12.1' id='jquery-ui-slider-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-includes/js/jquery/ui/tabs.min.js?ver=1.12.1' id='jquery-ui-tabs-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/plugins/timetable/js/jquery.ba-bbq.min.js?ver=aef9b5373b8bdd9055cb94bf6eaf8593' id='jquery-ba-bqq-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/plugins/timetable/js/jquery.carouFredSel-6.2.1-packed.js?ver=aef9b5373b8bdd9055cb94bf6eaf8593' id='jquery-carouFredSel-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/plugins/timetable/js/timetable.js?ver=aef9b5373b8bdd9055cb94bf6eaf8593' id='timetable_main-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/plugins/wp-smushit/app/assets/js/smush-lazy-load.min.js?ver=3.8.5' id='smush-lazy-load-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/vendors/gsap/gsap.min.js?ver=3.3.1.001' id='kalium-gsap-js-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/vendors/gsap/ScrollToPlugin.min.js?ver=3.3.1.001' id='kalium-gsap-scrollto-js-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/vendors/scrollmagic/ScrollMagic.min.js?ver=3.3.1.001' id='kalium-scrollmagic-js-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/vendors/scrollmagic/plugins/animation.gsap.min.js?ver=3.3.1.001' id='kalium-scrollmagic-gsap-js-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/js/sticky-header.min.js?ver=3.3.1.001' id='kalium-sticky-header-js-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/vendors/jquery-libs/jquery.ba-throttle-debounce.js?ver=3.3.1.001' id='kalium-jquery-throttle-debounce-js-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/vendors/fluidbox/jquery.fluidbox.min.js?ver=3.3.1.001' id='kalium-fluidbox-js-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-includes/js/wp-embed.min.js?ver=aef9b5373b8bdd9055cb94bf6eaf8593' id='wp-embed-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/vendors/gsap/SplitText.min.js?ver=3.3.1.001' id='kalium-gsap-splittext-js-js'></script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/vendors/light-gallery/lightgallery-all.min.js?ver=3.3.1.001' id='kalium-light-gallery-js-js'></script> <script type='text/javascript' id='kalium-main-js-js-before'>var _k = _k || {}; _k.stickyHeaderOptions = {"type":"standard","containerElement":".site-header","logoElement":".logo-image","triggerOffset":0,"offset":".top-header-bar","animationOffset":10,"spacer":true,"animateProgressWithScroll":true,"animateDuration":null,"tweenChanges":false,"classes":{"name":"site-header","prefix":"sticky","init":"initialized","fixed":"fixed","absolute":"absolute","spacer":"spacer","active":"active","fullyActive":"fully-active"},"autohide":{"animationType":"fade-slide-top","duration":0.3,"threshold":100},"animateScenes":{"styling":{"name":"style","selector":".header-block","props":["backgroundColor"],"css":{"default":{"backgroundColor":"rgba(255,255,255,0)"}},"data":{"tags":["transparent-header"]},"position":0},"sticky-logo":{"name":"sticky-logo","selector":"logo","props":["width","height"],"css":{"width":130,"height":63},"data":{"type":"alternate-logo","alternateLogo":"sticky","tags":["logo-switch"]},"position":0},"padding":{"name":"padding","selector":".header-block","props":["paddingTop","paddingBottom"],"css":{"default":{"paddingTop":15,"paddingBottom":15}},"position":0}},"alternateLogos":{"sticky":{"name":"sticky","image":"<img width=\"209\" height=\"102\" src=\"https:\/\/media.soc.northwestern.edu\/wnur\/2019\/08\/19211716\/main-logo-bl-01.svg\" class=\"attachment-original size-original\" alt=\"\" \/>"}},"supportedOn":{"desktop":1,"tablet":1,"mobile":1},"other":{"menuSkin":null},"debugMode":false};
var _k = _k || {}; _k.logoSwitchOnSections = [];
var _k = _k || {}; _k.enqueueAssets = {"js":{"light-gallery":[{"src":"https:\/\/wnur-transfer.soc.northwestern.edu\/wp-content\/themes\/kalium\/assets\/vendors\/light-gallery\/lightgallery-all.min.js"}]},"css":{"light-gallery":[{"src":"https:\/\/wnur-transfer.soc.northwestern.edu\/wp-content\/themes\/kalium\/assets\/vendors\/light-gallery\/css\/lightgallery.min.css"},{"src":"https:\/\/wnur-transfer.soc.northwestern.edu\/wp-content\/themes\/kalium\/assets\/vendors\/light-gallery\/css\/lg-transitions.min.css"}]}};
var _k = _k || {}; _k.require = function(e){var t=e instanceof Array?e:[e];return new Promise(function(e,r){var a=function(t){if(t&&t.length){var r=t.shift(),n=r.match( /\.js(\?.*)?$/)?"script":"text";jQuery.ajax({dataType:n,url:r}).success(function(){!function(e){var t;e.match( /\.js(\?.*)?$/)?(t=document.createElement("script")).src=e:((t=document.createElement("link")).rel="stylesheet",t.href=e);var r=!1,a=jQuery("[data-deploader]").each(function(t,a){e!=jQuery(a).attr("src")&&e!=jQuery(a).attr("href")||(r=!0)}).length;r||(t.setAttribute("data-deploader",a),jQuery("head").append(t))}(r)}).always(function(){r.length&&a(t)})}else e()};a(t)})};</script> <script type='text/javascript' src='https://wnur-transfer.soc.northwestern.edu/wp-content/themes/kalium/assets/js/main.min.js?ver=3.3.1.001' id='kalium-main-js-js'></script> </body></html><!-- WP Fastest Cache file was created in 0.12791800498962 seconds, on 08-06-21 17:32:29 --><!-- via php -->